Nginx中使用gzip_http_version解决CDN只支持http 1.0问题

网站经过CDN后,看CSS文件的header发现

复制代码代码如下:
Transfer-Encoding: chunked

google了许久,发现是CDN的抓取好像只支持http 1.0

nginx

gzip_http_version选项默认值为1.1

nginx配置文件中增加或修改gzip_http_version参数,为:

复制代码代码如下:
gzip_http_version 1.0

改完重启nginx

再看已经正常。

参考文档:http://wiki.nginx.org/NginxHttpGzipModule#gzip_http_version

http://forum.nginx.org/read.php?2,2630

本站大部分内容来自网络和网友投稿,如果侵犯了您的权益,请与我们联系,QQ:1101201144:Nginx开发与运维 » Nginx中使用gzip_http_version解决CDN只支持http 1.0问题

赞 (0)

评论 0

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址